Quick Sign In:  

Forum: VirtualDJ Plugins

话题: Echo lowpass setting not memorised
Each time I start VDJ (V8.5 arm b6839) I have to check the lowpass setting for each deck. Sometimes it remembers my setting (154 Hz) but randomly some of the 4 decks go to 592 Hz and the effect is totally gone. I searched where this setting is stored but can't find. Anyone a solution?
 

发表时间 Mon 14 Mar 22 @ 6:09 pm
locodogPRO InfinityModeratorMember since 2013
effect .ini are save as the settings for last used effect [deck] in a session.

If you have a desired config, use ONINIT mapping do do something like this.
deck all effect_slider 'echo' 3 20%
 

发表时间 Mon 14 Mar 22 @ 6:50 pm
Thanks for your answer @Locodog. For some reason I could find a file called 'effect.ini.'
After a search I found a folder 'Plugins64' with many native_effectname.ini files.
An .ini file for each effect.
When I open native_Echo.ini I see:
[autoparams]
Slider Strength 0=3360
Slider Length 1=2999
Slider Lowpass 2=0
Slider Highpass 3=4095
Switch Mute Source 4=0
Switch Trailing Stop 5=1

I changed the 'Slider Lowpass 2=' to 100. Save the file, restarted VDJ but the value remained 592.

Tried your 2th proposal and this was successfull. In the mapper for the keyboard settings, I found the 'e 'ONINIT'. Copy pasted your entry: deck all effect_slider 'echo' 3 20% and saved. Restarted VDJ and for all decks the echo effect setting for Lowpass is set to 119 Hz.

Many thanks!
 

发表时间 Tue 15 Mar 22 @ 8:42 pm
locodogPRO InfinityModeratorMember since 2013
oninit, is "on initialize", as in, automatically at start
every mapping has a oninit entry [including keyboard, in fact keyboard is probably the best one]
 

发表时间 Tue 15 Mar 22 @ 8:53 pm